Register    Login    Forum    Search    FAQ

Board index » General » Other Race Challenges, Shows & Events




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post Posted: September 12th, 2014, 6:01 pm 
Offline

Joined: January 10th, 2010, 8:08 pm
Posts: 145
I took part in the Brighton Speed Trials in the Supra on Saturday. However my day was not good!! I should have known when I found a pool of vomit from an overnight reveller in my pit space!

I did my practise run with a 12.68 at a slow 110mph - the track was fairly slippery and bumpy at the top end! When I got to the waiting area at the end of the track I let the car idle for a couple of minutes then switched off. When I went to restart to return to the pits the car wouldn't start! I got returned to the pits on the back of a recovery truck!

The engine would crank over but not catch. The only thing I noticed was that when I started the car for the practice run it was idleing roughly. I opened the glove box (where the Engine Management Unit is located) and when I closed it the engine seemed to run normaly. The only thing I could think of was that there was a loose wire connecting the Engine Management Unit to the wiring system!

When I got back to the pits I looked under the dash and wiggled a few wires that seemed to be going into the back of the glove box. Amazingly the car started!

So I lined up for my first timed run. As I was in the queue there was a delay so I turned the engine off - and guess what it wouldn't restart!

I tried fiddling again with the wiring but with no positive effect!

So I ended the day having the car picked up by the breakdown recovery and returned home. I have booked the car in at the tuners to see if they can fix it.

I never even got to see any of the other cars/bikes run!

The winner of my class was a Nissan GT-R (4 wheel drive) with a 11.38 second run @ 125mph.

The fastest time of the day was a bike (Suzuki Hayabusa Turbo) at 8.94 @ 169mph while the fastest car was a Force SR4 (Sports Libre class) with
10.43 @ 136mph.

Not my best Brighton Speed Trials!!

Simon


Top 
 Profile  
 
 Post Posted: September 14th, 2014, 7:02 pm 
Offline
User avatar

Joined: December 10th, 2009, 7:51 pm
Posts: 5430
Location: Norfolk
Not a good day by the sounds of it Simon, thanks for the write up makes for an interesting read.


Top 
 Profile  
 
 Post Posted: September 14th, 2014, 7:24 pm 
Offline

Joined: May 27th, 2014, 11:12 pm
Posts: 92
Location: plumstead, london
Always wanted to come watch this, my friend noel use to run his escort cossie there, not sure if hes finished his fiesta cosworth yet


Top 
 Profile  
 
 Post Posted: September 14th, 2014, 11:24 pm 
Offline

Joined: December 12th, 2009, 7:36 am
Posts: 972
Location: Wanstead, London.
Sorry to hear that Simon, lets hope its an easy fix.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 4 posts ] 

Board index » General » Other Race Challenges, Shows & Events


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron